大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 大智慧公式 > 正文

指标源码:大智慧新拾金图公式源码(公式)

2013-09-12 00:00:00 大智慧公式大全,大智慧公式源码
摘要: 买好股公式文章飞狐机构资金运作指数公式源码,介绍飞狐,机构,资金,指数,公式,源码炒股技巧,让您在股市里买到好股票。input:N(34,1,100),M(3,1,100);个股资金指数:EMA(((100 * (CLOSE - LLV(LOW,N))) / (HHV(HIGH,N) - LLV(LOW,N))),M);FILLRGN((个股资金指数 > (0 - 5)),100,(0 - 5)),color5500;FILLRGN((个股资金...量能,该股,箱底,黄金,智能大智慧新拾金图公式源码公式 源码SSL:=EMA(C,3);MMV:=EMA(((SLOPE(C,22) * 20) + C),55);MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),

SSL:=EMA(C,3);
MMV:=EMA(((SLOPE(C,22) * 20) + C),55);
MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );
STICKLINE(((SSL > MM) ),SSL,MM,0.1,0),colorred;
SA:=(MM * 0.985);
SS:=(MA(C,5));
DD:=(MA(C,13));
GG:=(MA(C,21));
捞钱手:IF(((SSL > MM)),MM,SA),LINETHICK2,colorFF00FF;
V2Y:=(((C - REF(C,1)) / REF(C,1)) * 100);
V3Y:=(((C - REF(O,29)) / REF(O,29)) * 100);
V4Y:=REF(C,1);
V5Y:=((SMA(MAX((C - V4Y),0),6,1) / SMA(ABS((C - V4Y)),6,1)) * 100);
V6Y:=((SMA(MAX((C - V4Y),0),12,1) / SMA(ABS((C - V4Y)),12,1)) * 100);
V7Y:=((SMA(MAX((C - V4Y),0),24,1) / SMA(ABS((C - V4Y)),24,1)) * 100);
V8Y:=(((C - LLV(L,45)) / (HHV(H,45) - LLV(L,45))) * 100);
V9Y:=SMA(V8Y,3,1);
VAY:=SMA(V9Y,3,1);
VBY:=((3 * V9Y) - (2 * VAY));
VCY:=(CROSS(V5Y,10) AND (V3Y < (0 - (28 * 20))));
VDY:=((100 - CROSS(76,V5Y)) AND (V3Y > (5 * 20)));
DRAWICON(((CROSS(76,V5Y) AND (V3Y > 5)) ),(H * 1.01),5),colorFFFFFF;
VEY:=((((CROSS(V9Y,VAY) AND (VAY < 10)) AND (V3Y < (0 - 30))) AND (V2Y > 3)) * 30);
VFY:= - ((((VAY < 11) AND (V5Y < 15)) AND (V3Y < (0 - 26))) * 10);
DRAWICON((CROSS(VFY,(0 - 9))),(L * 0.998),4);
能量线:=DMA(((C + O) / 2),(V / (SMA(V,4,1) * 4)));

上开:=o;
上收:=c;
上高:=h;
上低:=l;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
B:REF(A,1),POINTDOT,ColorYellow;
智能黄金线:A,ColorYellow,LINETHICK1;
STICKLINE(((SSL < MM) ),捞钱手,智能黄金线,0.1,0),COLORCYAN;
VA1:=EMA(上收,8);
VA2:=EMA(上收,20);
DRAWTEXT(CROSS(VA2,VA1),VA1*1.10,'止损'),ALIGN1,ColorYellow;
DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 智能黄金线>REF(智能黄金线,1),VA1*0.98,'★买入'),COLOR00FF00;
选手A:=MA(上收,3);
箱顶A:=MA(REF(HHV(上收,6),1),3);
箱底A:=MA(REF(LLV(上收,3),1),3);
t1:=MA(上收,20)>=REF(MA(上收,20),1);
t2:=CROSS(选手A,箱底A) AND 箱顶A/箱底A>100/100 AND t1;
t3:=CROSS(箱顶A,选手A) AND 箱顶A/箱底A>100/100;
选手:=MA(上收,2);
箱顶:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
t4:=CROSS(选手,箱底) AND 箱顶/箱底>110/100;
t5:=CROSS(箱顶,选手) AND 箱顶/箱底>110/100;
V1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
V2:=SMA(V1,3,1);
V3:=SMA(V2,3,1);
V4:=SMA(V3,3,1);
DRAWTEXT(V3 >=V4 and BARSTATUS=2,箱顶,'--中期好'),COLOR00FFFF;
DRAWTEXT( V3<V4 and BARSTATUS=2,箱顶,'--中期坏'),COLORf0f000;
DRAWTEXT( A>B and BARSTATUS=2,箱底,'--短期好'),COLOR00FFFF;
DRAWTEXT(A<B and BARSTATUS=2,箱底,'--短期坏'),COLORf0f000;
mms:=ma(sma((l+h+2*c)/4-ref((l+h+2*c)/4,1),5,1)/sma(abs((l+h+2*c)/4-ref((l+h+2*c)/4,1)),5,1)*100,1)+50;
g1:=if(-mms>95,0,20);
uoo:=(-(((C-LLV(C,7))/(HHV(C,7)-LLV(C,7))*100=100)>0 and g1)+1);
DRAWTEXT(CROSS(V3,V4)AND(C>=O)AND V3<40 AND uoo>0,箱底,'★'),ALIGN0,COLORf00ff0;
DRAWTEXT(CROSS(V4,V3) AND V4>75 ,箱顶*1.03,'★减磅'),COLORf0f000;
{K线卖提示}
Qc0:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);
stickline(Qc0>=91 AND (C-LLV(C,5))/(HHV(C,5)-LLV(C,5))*100>99.9,O,C,3,0),COLOR3366FF;
stickline(Qc0>=91 AND (C-LLV(C,5))/(HHV(C,5)-LLV(C,5))*100>99.9,H,L,0.5,0),COLOR3366FF;
{K线超卖提示}
SQ1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
SQ2:=SMA(MAX(C-REF(C,1),0),7,1)/SMA(ABS(C-REF(C,1)),7,1)*100;
CM1:=IF(SQ1<12,30,0);
CM2:=IF(SQ2<12,30,0);
Zb1:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10))*100;
www:=Zb1<1;
w:=if(WWW,-20,0);
A01:=SMA(ABS((L - REF(L,1))),3,1) / SMA(MAX((L - REF(L,1)),0),3,1) *100;
A02:=EMA(IF(C *1.3,A01 *10,A01 /10),3);
A03:=LLV(L, 30);
A04:=HHV(A02, 30);
A05:=EMA(IF((L <= A03),(A02 + A04*2)/2,0),3) /6180 *2.5;
A06:=IF((A05 >15),15,A05);
Kx:=if(A06>=1.7,-20,0);
Zy:=MA(((C-MA(C,6))/MA(C,6)*100+2*(C-MA(C,12))/MA(C,12)*100+3*(C-MA(C,24))/MA(C,24)*100)/6,3);
Zy1:=IF(Zy<-6,-20,0);
KS:=(((C - SMA(C,13,1)) / SMA(C,13,1)) * (0 - 100));
RKS:=REF(KS,1);
MLS:=((((RKS / KS) > 1.23) AND (RKS > 13)) AND ((C / REF(C,1)) > 1.03));
{超卖一}STICKLINE(CM1 and IF(Kx and w and Zy1,-16,10)<0,L,L*0.998,7,0),Color0089FF{超卖一:橙};
{超卖二}STICKLINE(IF(Kx and w and Zy1,-16,10)<0 and CM1,L*0.998,L*0.996,7,0),COLORgreen{超卖二:绿};
{超跌}STICKLINE(CM1 and IF(Kx and w and Zy1,-16,10)<0 AND(KS>13),L*0.996,L*0.994,7,0),ColorYellow{超跌};
{反弹}STICKLINE((MLS=1),L,L*0.998,7,0),ColorFFFF00;

{K线买提示}
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);

Fk:=100*(C-REF(C,1))/REF(C,1);
pk1:=IF(C<REF(O,1) AND fk<0,1,0);
pk2:=IF(C<REF(O,2) AND fk<0,1,0);
pk3:=(((C / O) > 1.04) AND (C <(SMA(H,21,2) * 1.05))) AND ((C - REF(C,1)) > 0);
stickline((Pk1=0 AND REF(Pk1,1)=1 AND Pk2=0 AND REF(Pk2,1)=1),O,C,3,0),COLORMAGENTA;
stickline((Pk1=0 AND REF(Pk1,1)=1 AND Pk2=0 AND REF(Pk2,1)=1),H,L,0.5,0),COLORMAGENTA;
STICKLINE(pk3 AND(趋势线>REF(趋势线,1)OR 智能黄金线>REF(智能黄金线,1)),C,O,3,0),COLORMAGENTA;
STICKLINE(pk3 AND(趋势线>REF(趋势线,1)OR 智能黄金线>REF(智能黄金线,1)),H,L,0.5,0),COLORMAGENTA;

买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
STICKLINE(买进条件 AND 捞钱手>智能黄金线 AND 智能黄金线>REF(智能黄金线,1),L,L*0.998,7,0),COLORWHITE;

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
DRAWTEXT(cross(买线,卖线)AND 箱顶>=REF(箱顶,1),箱底,'★'),ALIGN0,color00ffff;
stickline(cross(买线,卖线),O,C,3,0),color00ffff;
stickline(cross(买线,卖线),h,l,0.5,0),color00ffff;

A4:=MA(C,20);
A5:=(C > MA(C,5));
A6:=(MA(C,5) > MA(C,10));
A7:=(C > MA(C,10));
A8:=(MA(C,5) > MA(C,20));
A9:=(C > MA(C,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(C / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(V,5);
V2:=MA(V,10);
阻力位:=IF((C > 200),(C * 1.01),(C * 1.07));
阻力位1:=IF((C < 10),(C * 1.05),阻力位);
止损位:=IF((C > 200),(C * 0.99),(C * 0.93));
止损位1:=IF((C < 10),(C * 0.95),止损位);
TJTS1:=BARSTATUS=2 and c<200;
TJTS2:=BARSTATUS=2 and c>200;
k2:=hhv(h,barslast(DISPSTATUS=1)+1);
DRAWTEXT(TJTS1 or TJTS2 ,箱顶,'阻力位: '+NUMTOSTRN(阻力位1,2)+' '),COLORWHITE,ALIGN2;
DRAWTEXT(TJTS1 or TJTS2 ,箱底,'止损位: '+NUMTOSTRN(止损位1,2)+' '),COLORWHITE ,ALIGN2;

DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。'),ALIGN2,color0000FF;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。'),ALIGN2,color0000FF;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。'),ALIGN2,color0000FF;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。'),ALIGN2,color0000FF;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。'),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。'),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股放量下跌,走势明显偏弱,离场观望。'),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股缩量下跌,走势偏弱,离场观望。'),ALIGN2,color00FF00;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股形态良好,强势明显,量能充足,可以继续持有。'),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。'),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股走势趋弱,量能不足,减持大部分筹码。'),ALIGN2,color00FFFF;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股形态不佳,注意成交量的变化,但目前不适合参与。'),ALIGN2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),ALIGN2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股有走强迹象,但量能不足,趋势不明,不适合操作。'),ALIGN2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'该股走势太弱,没有参与价值。'),ALIGN2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.99,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右,'),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.98,' 如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。'),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.99,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌,'),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.98,' 可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。'),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 >= V2)) ,k2*0.99,'大盘形态走坏,重仓者可以减去大部分仓位。'),ALIGN2,color00FF00;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 < V2)) ,k2*0.99,'大盘缩量调整,注意风险,短线清仓观望。'),ALIGN2,color00FF00;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) ,k2*0.99,'大盘走势良好,量能理想,可以继续持有强势股。'),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) ,k2*0.99,'大盘形态良好,但量能稍显不足,随时准备减仓。'),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) ,k2*0.99,'大盘趋势不明,注意成交量变化,目前不适宜进场。'),ALIGN2;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) ,k2*0.99,'大盘趋势向下,量能萎缩,不适合进场。'),ALIGN2;


 





  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:量能,该股,箱底,黄金,智能
相关阅读:
  • >>指标公式:大智慧的吸筹与10日均线的讨论指标公式(日均)
    买好股公式文章大智慧的吸筹与10日均线的讨论指标公式,介绍均线,,吸筹,,大智慧炒股技巧,让您在股市里买到好股票。大智慧的吸筹公式及图形如下。如果翻一翻股票,发现很多都是在低于10日均线之后开始吸筹的。VAR2:=REF(LOW,1);VAR3:=SMA(A...
  • >>指标公式:通达信长线狂赚选股公式源码(公式)
    买好股公式文章通达信长线狂赚选股公式源码,介绍通达信,长线,选股,公式,源码炒股技巧,让您在股市里买到好股票。MA5 :MA(CLOSE,5),NODRAW;{www。57ee。net 大智慧公式}MA10:MA(CLOSE,10),NODRAW;MA20:MA(CLOSE,20),NODRAW;MA30:MA(CLOSE,3...
  • >>公式源码:通达信KDJMACD分日共振副图公式源码(副图)
    买好股公式文章通达信KDJMACD分日共振副图公式源码,介绍共振,副图,源码炒股技巧,让您在股市里买到好股票。{公式源码网选编}该指标试探通过KDJ和MACD指标的30分钟、60分钟以及日、周线彩条的变化情况,显示出共振点,为大家提供操盘买卖的...
  • 关键字: