大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 同花顺公式 > 正文

指标源码:同花顺背离主图指标公式(主图)

2011-01-12 00:00:00 同花顺公式下载
摘要: 大盘参照 副图源码涨家数:INDEXADV,COLORWHITE,NODRAW;跌家数:INDEXDEC,COLORGREEN,NODRAW;涨跌比:涨家数/(涨家数+跌家数)*100;二日涨跌比:SUM(涨跌比,2),NODRAW ;涨幅:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,NODRAW;STICKLINE(二日涨跌比<40,0,66,1,0),COLORRED;STICKLINE((涨跌比<14 OR 涨幅<-1.5),66...选编,公式,指标同花顺背离主图指标公式主图 同花顺 背离 公式 指标ma1:MA(C,5);{指标公式网选编}ma2:MA(C,10);ma3:MA(C,30);A1:=BARSLAST(REF(CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));B1:=REF(C,A1+1)>C AND REF("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) AND CROSS("macd.diff"(12,2

ma1:MA(C,5);
{指标公式网选编}
ma2:MA(C,10);
ma3:MA(C,30);
A1:=BARSLAST(REF(CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) AND CROSS("macd.diff"(12,26,9),"macd.dea"(12,26,9));
底背离MACD:DRAWTEXT(FILTER(B1>0,5),LOW,'1'),coloryellow;
DRAWTEXT(FILTER(B1>0,5),LOW*0.98,'MACD底背离'),COLOR00ff00;
A2:=BARSLAST(REF(CROSS("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) AND CROSS("kdj.k"(9,3,3),"kdj.d"(9,3,3));
底背离KDJ:DRAWTEXT(FILTER(B2>0,5),LOW,'▲'),coloryellow;
DRAWTEXT(FILTER(B2>0,5),LOW*0.98,'KDJ底背离'),colorred;
A3:=BARSLAST(REF(CROSS("RSI.RSI$1"(12,26,9),"RSI.RSI$2"(12,26,9)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI$1"(8,55,55),A3+1)<"RSI.RSI$1"(8,55,55) AND CROSS("RSI.RSI$1"(8,55,55),"RSI.RSI$2"(8,55,55));
底背离RSI:DRAWTEXT(FILTER(B3>0,5),LOW,'▲'),coloryellow;
DRAWTEXT(FILTER(B3>0,5),LOW*0.98,'RSI底背离'),colorf0f000;
A4:=BARSLAST(REF(CROSS("dmi_ql.pdi"(14,6),"dmi_ql.mdi"(14,6)),1));
B4:=REF(C,A4+1)>C AND REF("dmi_ql.pdi"(14,6),A4+1)<"dmi_ql.pdi"(14,6) AND CROSS("dmi_ql.pdi"(14,6),"dmi_ql.mdi"(14,6));
底背离DMI:DRAWTEXT(FILTER(B4>0,5),LOW,'▲'),coloryellow;
DRAWTEXT(FILTER(B4>0,5),LOW*0.98,'DMI底背离'),colorF00FF0;
C1:=BARSLAST(REF(CROSS("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) AND CROSS("macd.dea"(12,26,9),"macd.diff"(12,26,9));
顶背离MACD:DRAWTEXT(FILTER(D1>0,5),HIGH*1.02,'▲'),COLOR00FF00;
DRAWTEXT(FILTER(D1>0,5),HIGH*1.04,'MACD顶背离'),colorred;
C2:=BARSLAST(REF(CROSS("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) AND CROSS("kdj.d"(9,3,3),"kdj.k"(9,3,3));
顶背离KDJ:DRAWTEXT(FILTER(D2>0,5),HIGH*1.02,'▲'),COLOR00FF00;
DRAWTEXT(FILTER(D2>0,5),HIGH*1.04,'KDJ顶背离'),COLORF00FF0;
C3:=BARSLAST(REF(CROSS("RSI.RSI$2"(8,55,55),"RSI.RSI$1"(8,55,55)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI$1"(8,55,55),C3+1)>"RSI.RSI$1"(8,55,55) AND CROSS("RSI.RSI$2"(8,55,55),"RSI.RSI$1"(8,55,55));
顶背离RSI:DRAWTEXT(FILTER(D3>0,5),HIGH*1.02,'▲'),COLOR00FF00;
DRAWTEXT(FILTER(D3>0,5),HIGH*1.04,'RSI顶背离'),coloryellow;
C4:=BARSLAST(REF(CROSS("DMI_ql.MDI"(14,6),"DMI_ql.PDI"(14,6)),1));
D4:=REF(C,C4+1)<C AND REF("DMI_ql.PDI"(14,6),C4+1)>"DMI_ql.PDI"(14,6) AND CROSS("DMI_ql.MDI"(14,6),"DMI_ql.PDI"(14,6));
顶背离DMI:DRAWTEXT(FILTER(D4>0,5),HIGH*1.02,'▲'),COLOR00FF00;
DRAWTEXT(FILTER(D4>0,5),HIGH*1.04,'DMI顶背离'),COLORF0F000;



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:选编,公式,指标
相关阅读:
  • >>源码-通达信回归斜率线公式源码图(斜率)
    买好股公式文章通达信回归斜率线公式源码图,介绍源码炒股技巧,让您在股市里买到好股票。 回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1...
  • >>公式-通达信好指标一个指标公式(指标)
    { N 2, 9, 14 M 2 60 6}MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);HD :=HIGH-REF(HIGH,1);LD :=REF(LOW,1)-LOW;DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);上...
  • >>公式源码:大智慧能量对比公式源码(公式)
    买好股公式文章大智慧能量对比公式源码,介绍大智慧,智慧,公式,源码炒股技巧,让您在股市里买到好股票。INPUT:N(70,1,999),M(5,1,120);ZSC:=IF(INBLOCK('工程建筑'),"991002$CLOSE",IF(INBLOCK('电力'),"991003$CLOSE",IF(INBLOCK('计算机'...
  • 关键字: