大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 公式编写 > 正文

源码-大智慧公式编辑教程 第十一章:公式编码答疑123(公式)

2010-06-12 13:57:36 选股公式编写,股票公式编写
摘要: 买好股公式文章通达信股易顶底指标公式,介绍炒股技巧,让您在股市里买到好股票。Var1:((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3; 0, VOLSTICK; 拉升%: IF(Var1>0,Var1,0), , colorred; 短顶: STICKLINE(Var1>9 AND FILTER(Var1< RE...主图,公式,指标,日均,天线大智慧公式编辑教程 第十一章:公式编码答疑123公式 答疑 编码 编辑 教程小指标公式编码集中答(一)1.成交量连续5天超过30天均量点count(vol>ma(vol,30),5)=52.选股公式;要求1;日均线多头排列的情况下(5,10,30,60。。。)2:5日。10日均线高度粘合--相等或相差1-2分钱,30均线与5,10均线相差1角以下。3:日量比大于2。1.ma(c,5)>ma(c,10) and ma(c,10)>ma(c,30) and ma(c,30

小指标公式编码集中答(一)


1.成交量连续5天超过30天均量点
count(vol>ma(vol,30),5)=5

2.选股公式;要求
1;日均线多头排列的情况下(5,10,30,60。。。)
2:5日。10日均线高度粘合--相等或相差1-2分钱,30均线与5,10均线相差1角以下。
3:日量比大于2。
1.ma(c,5)>ma(c,10) and ma(c,10)>ma(c,30) and ma(c,30)>ma(c,60) and 。。。
2.abs(ma(c,5)-ma(c,10))<0.03 and abs(ma(c,30)-max(ma(c,5),ma(c,10)))<0.1
3.DYNAINFO(17)>2

3.威力雷达rad7日内连续上扬怎样编写?
V1:=(c/ref(c,1)-indexc/ref(indexc,1))*200;
RAD:=sum(v1,0);

count(rad>ref(rad,1),7)=7

威力雷达Mrad在7日内连续上扬怎样编写?
V1:=(c/ref(c,1)-indexc/ref(indexc,1))*200;
RAD:=sum(v1,0);

MRAD:=MA(RAD,30);

count(mrad>ref(mrad,1),7)=7

4.请问。10日内涨幅大于10%的选股公式怎样编?
c/ref(c,10)>1.1

5.如何编写股价在一个上涨或下跌的行情中第3次触及30日均线时发出提醒的指标?
M3:=MA(C,30);

N1:=BARSLAST(M3>REF(M3,1));

AA:=CROSS(C,M3);

COUNT(AA,N1)=3

6.请问:cys指标中数值要小于-5,怎样编写到其他指标中.,谢谢!
(C-CYC(13))/CYC(13)*100<-5


7.当涨幅大于5%,要主图K线的实体的一半变为另一色。如何表达?
STICKLINE(c/ref(c,1)>1.05,(c+o)/2,c,10,1),coloryellow;

8.成交量连续3天涨的公式
COUNT(VOL>REF(VOL,1),3)=3

9.请问怎样用公式表示年线摆脱下降趋势出现向上拐头?
COUNT(MA(C,250)>REF(MA(C,250),1),3)=3

10.股价创出新高后,又调整到30日均线附近的选股公式如何编写?

COUNT(C>=HHV(C,N),5)=1 AND C/MA(C,30)>=1 AND C/MA(C,30)<1.02

11.怎么定义一阳线紧跟两阴线的函数?
ref(c,2)>ref(o,2) and ref(c,1)<ref(o,1) and c<o;

12.60日线在过去的10天内涨跌幅度在 1%
COUNT(BETWEEN(ma(c,60),ref(ma(c,60),10)*1.01,ref(ma(c,60),10)*0.99),10)=10;

13.RSI(周线)在70天内第二次上穿80,如何编制?
COUNT(CROSS("RSI.RSI1#WEEK",80),70)=2

14.今天涨幅3%昨天涨幅2%前天涨幅1%的个股
(c-ref(c,1))/ref(c,1)>0.3 and (ref(c,1)-ref(c,2))/ref(c,2)>0.2 and (ref(c,2)-ref(c,3))/ref(c,3)>0.1

15.破5天线,3天后又重新站上5天线的个股
cross(ref(ma(c,5),3),ref(c,3)) and cross(c,ma(c,5))

16.今天一阳上穿5,10,30天线个股
cross(c,ma(c,5) and cross(c,ma(c,10)) and cross(c,ma(c,30))

17.3天内5天线上穿10天线,10天线上穿20天线的个股
count(cross(ma(c,5),ma(c,10)),3)>=1   and   count(cross(ma(c,10),ma(c,20)),3)>=1

18.日macd翻绿3内又翻红的个股。
count(cross(0,"MACD.MACD" ),3)=1 and count(cross("MACD.MACD",0 ),3)=1

19.5天线拐头向下3天内又拐头向上的个股。
count(cross(ref(ma(c,5),1),ma(c,5)),3)=1 and count(cross(ma(c,5),ref(ma(c,5),1)),3)=1

20.收盘价比开盘价高出6%,当日涨幅超过6%,实体占整天振幅的80%以上
C/O>1.06 AND C/REF(C,1)>1.06 AND C-O>0.8*(H-L)

 小指标公式编码集中问答(二)

1.怎样编制全市场平均价格公式

现在的指数不能说明市场真实平均价格,怎样写才准确呢?

沪股均价:"1A0002$AMOUNT"/"1A0002$VOL"/100;
深股均价:"399107$AMOUNT"/"399107$VOL"/100;
均价:("1A0002$AMOUNT"+"399107$AMOUNT")/("1A0002$VOL"+"399107$VOL")/100;

2.用股价选股

input.:年(2004),月(8),日(31),最小价格(1),最大价格(2);
n:=DATEDIFF(((年-1900)*10000+月*100+日),DATE);//计算输入日期和现在日期周期
tj:REF(CLOSE,n)>最小价格 and REF(CLOSE,n)<最大价格;

3.
1,股价突破60日均线的选股公式,
2,和怎么选出一段时间以来的涨停板个股公式
1
cross(c,ma(c,60));
2
f:=ref(c,1)*1.1-c<0.01;
count(f,n)>0;//N天内出现过涨停

4.股价横盘,MACD金叉,然后股价创新底,MACD没死叉。
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=0.04
AND c<ref(LLV(L,N),1) and "macd.diff">"macd.dea";

5.过滤一个条件成立的信号

过滤:=(EMA(C,60)>EMA(C,30))>(EMA(C,60)>EMA(C,30)*1.05);

我需要这个信号以外成立的信号
过滤:=(EMA(C,60)>EMA(C,30))>(EMA(C,60)>EMA(C,30)*1.05);
not(过滤)
***
IF(过滤,0,1);

6.收盘价在20日均线之上,收盘价连升二天。
f:=c/ref(c,1);
count(c>ma(c,20) and f>1,2)=2;

7.求最大值?

在飞狐中如何求以下四个代数式中的最大值
a-b,b-c,a-c,d-c
MAX(A,B)只能返回A和B中的较大值?
MAX(MAX(A,B),MAX(C,D));

8、通用的"二次金叉"通式。

Jm:=CROSS("指标名称.指标线1","指标名称.指标线2");
JmCOUNT:=COUNT(Jm,BARSLAST("指标名称.指标线1(或指标线2)"大于或小于某数));
Jmtj:40*("指标名称.指标线1(或指标线2)"小于或大于某数));
Drawtext (Jmtj,40,'…………二次金叉');
条件选股:60*(Jmtj and …………),colorgreen;

9、例如(这里给出三个例子)
1、Macd在0轴线以下二次金叉
Jm:=CROSS("Macd.DIFF","Macd.DEA");
JmCOUNT:=COUNT(Jm,BARSLAST("Macd.DEA">=0));
Jmtj:40*("Macd.DEA"<0 and Count(JmCount=2,21)=1);
Drawtext (Jmtj,40,'Macd在0轴线以下二次金叉');
条件选股:60*(Jmtj and Slope(Ma(C,5),2)>0),colorgreen;
Drawtext (条件选股,50,'5日3%成功率:44.71%');

2、KD在60轴线以下二次金叉
Jm:=CROSS("KD.K","KD.D");
JmCOUNT:=COUNT(Jm,BARSLAST("KD.D">=60));
Jmtj:40*("KD.D"<60 and Count(JmCount=2,21)=1);
Drawtext (Jmtj,"KD.D",'KD在60轴线以下二次金叉');
条件选股:60*(Jmtj and Slope(Ma(C,20),3)>0),colorgreen;
Drawtext (条件选股,50,'5日3%成功率:50.3%');

3、SlowKD在30轴线以下二次金叉
Jm:=CROSS("SlowKD.K","SlowKD.D");
JmCOUNT:=COUNT(Jm,BARSLAST("SlowKD.D">=30));
Jmtj:28*("SlowKD.D"<30 and Count(JmCount=2,21)=1);
Drawtext (Jmtj,28,'SlowKD在30轴线以下二次金叉');
条件选股:50*(Jmtj and Slope(Ma(C,20),2)>0),colorgreen;

10.求各位高手写一个选股公式!

N天,N日均线,以N角度向上或向下运行的均线。(分析家)

atan((ma(c,n)-ref(ma(c,n),N))/N); //值为正向上,值为负向下

11.K线中"低点不断抬高"和"低点不断降低"的指标如何编 ?

l>ref(l,1) and REF(L,1)>ref(l,2) and REF(L,2)>ref(L,N);;{N,5,1,999}
"低点不断抬高"
反之<是"低点不断降低"

12.符号编公式用

【】〓☆★○●◎◇◆□■△▲ⅠⅡⅢⅣⅤⅥⅦⅧⅨⅩ→←↑↓^§∧∨∪∩∈∞∝⊥∽√┣┫┻╋┼αβδωΩφΦΨΠ┳

13.当收盘价收在7天平均线上,K线都为阳线(红色),收盘价收在7天平均线下,K线都为阴线(录色),在主图怎样写?
stickline(c>=ma(c,7),c,o,7,0),colorred;
stickline(c>=ma(c,7),h,l,1,0),colorred;
stickline(c<ma(c,7),c,o,7,0),colorgreen;
stickline(c<ma(c,7),h,l,1,0),colorgreen;

14.20日内次高点
AA:=HHVBARS(C,20);
C=MAX(HHV(C,AA),REF(HHV(C,19-AA),AA+1));

15.要选出收市价离125天均线不远,
ABS(C-MA6)/MA6<=0.01

20.写均线MA1二次上穿MA4公式!
COUNT(CROSS(ma1,ma4),20)=2;

小指标公式编码集中(三)

这是在网上摘录的,仅供参考
编写公式时常用的通式
应用 FXJ-4 的一些函数编写公式时,常用的通式:
{设A,B,R为三条曲线;N,M等为参数。如:A:ma(c,N) ; B:=ma(c,M); R:=c/ref(c,1)-1;等。。。}
{一.曲线在N天内的平均变化率}
Fa:=(A/ref(A,N)-1)/N; Fb:=(B/ref(B,N)-1)/N; Fr:=(R/ref(R,N)-1)/N;
{二.变动角}
∮a:=atan(Fa);    ∮b:=atan(Fb);  ∮r:=atan(Fr);
{三.曲线上相距N天的两点的连线的斜率}
Ka:=(A-ref(A,N))/N;   Kb:=(B-ref(B,N))/N; Kr:=(R-ref(R,N))/N;
{四.倾角}
∠a:=atan(Ka);   ∠b:=atan(Kb);   ∠r:=atan(Kr);
{五.交*点}
Cab:=cross(A,B);{交*} Jab:=longcross(A,B,N);{维持 -交*}
JYa:=between(A,N,M);{介于} FWa:=range(A,N,M);{范围}
{六.下拐点(由下向上转)}
xD1:=llvbars(A,N)=M;{以N日最低点}
xD2:=ref(count(A-ref(A,1)<=0,N)=N,M) and count(A-ref(A,1)>0,M)=M;{以M日变化量的正负}
xD3:=ref(count(∠a-ref(∠a,1)<=0,N)=N,M) and ∠a>0;{以当日变化角的正负}
{七.上拐点(由上向下转)}
sD1:=hhvbars(A,N)=M;{以N日最低点}
sD2:=ref(count(A-ref(A,1)>=0,N)=N,M) and count(A-ref(A,1)<0,M)=M;{以当日变化量的正负}
sD3:=ref(count(∠a-ref(∠a,1)>=0,N)=N,M) and ∠a<0;{以当日变化角的正负}
{八.位置(求得交*点/拐点到当前的周期)}
Wz1:=barslast(Cab);{第一(交*)点的位置}
Wz2:=ref(Wz1,Wz1+1)+Wz1+2;{第二(交*)点的位置}
Wz3:=ref(Wz1,Wz2+1)+Wz2+2;{第三(交*)点的位置}
Wz4:=ref(Wz1,Wz3+1)+Wz3+2;{第四(交*)点的位置}
Wz5:=ref(Wz1,Wz4+1)+Wz4+2;{第五(交*)点的位置}
{Wzn:=ref(Wz1,Wz(n-1)+1)+Wz(n-1)+2;}
{九.曲线A叠加曲线B}
F:=A/ref(A,1)-1;{A的变化率}
Js:=ref(B,barscount(c));{叠加位置(初始)}
DJ:=sum(F,0)+1)*Js;{叠加曲线(初始位置)}
Jd:=ref(B,barslast(条件));{叠加位置(定点)}
Dh:=(sum(F,0)+1)*Jd;{叠加曲线(预定位置)}

{点击看本软件截图:分.析家公 式网 http://www、gongshi8、com 整理}

  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:主图,公式,指标,日均,天线
相关阅读:
  • >>公式源码:通达信周KDJ指标公式(公式)
    买好股公式文章通达信周KDJ指标公式,介绍KDJ炒股技巧,让您在股市里买到好股票。周J1:=MA("KDJ.J#WEEK"(9,3,3) ,5);STICKLINE(周J1>0,周J1,0,2,周J1);DRAWICON(CROSS(周J1,68),周J1*2.03,1);DRAWICON(CROSS(周J1,5),周J1*-0.92,5);...
  • >>源码-通达信阶段底部选股公式源码(公式)
    买好股公式文章通达信阶段底部选股公式源码,介绍底部,选股,源码炒股技巧,让您在股市里买到好股票。操作说明:偶的一个公式中提出的小东东,简单改一下,分析趋势还不错,分享给童鞋,选股买票重要一条是看票的趋势,选择向上走趋势票会有...
  • >>指标公式:同花顺魔鬼操盘主图公式源码(主图)
    买好股公式文章同花顺魔鬼操盘主图公式源码,介绍同花顺,操盘,主图,公式,源码炒股技巧,让您在股市里买到好股票。均5:MA(CLOSE,5), coloryellow;{www。zhibiao8。com 指标公式}均10:MA(CLOSE,10), COLORf00ff0;均30: MA(CLOSE,30), COLOR00...
  • 关键字: